'Delete after' not applied to snapshots copied to other region

Topics related to Version 3 of AutomatiCloud
Post Reply
chris
Posts: 20
Joined: Fri Nov 27, 2015 2:19 am

'Delete after' not applied to snapshots copied to other region

Post by chris » Wed Jan 25, 2017 5:28 am

I'm using your 'Backup EC2 Instance' job type to do daily backups of my instances and on these jobs I also make use of the 'Copy to region' feature for DR purposes.

I've set GFS 'Delete after' values for these jobs and was expecting the snapshots to be cleaned up in both the originating and 'copy to' regions. However today I notice they haven't been getting deleted in the 'copy to' region which is unexpected?

I think AutomatiCloud should be able to clean up these copied snapshots also. Otherwise users will need to periodically delete these manually.

admin
Site Admin
Posts: 220
Joined: Tue Nov 17, 2015 8:48 pm

Re: 'Delete after' not applied to snapshots copied to other region

Post by admin » Tue Feb 07, 2017 6:10 pm

fixed in Version 3.3.820

Stephan

chris
Posts: 20
Joined: Fri Nov 27, 2015 2:19 am

Re: 'Delete after' not applied to snapshots copied to other region

Post by chris » Mon Mar 27, 2017 11:27 pm

Hi Stephan,

Following your reply above I upgraded to 3.3.820 and cleaned up all the old snapshots in my 'copy to region'. I've then been running daily backups for over a month to test it as I have the job set to 'Delete after 30 days'. However I just checked it and see that old snapshots are not being deleted at all? Is this still a bug?

Regards,
Chris

admin
Site Admin
Posts: 220
Joined: Tue Nov 17, 2015 8:48 pm

Re: 'Delete after' not applied to snapshots copied to other region

Post by admin » Thu Mar 30, 2017 10:12 am

Can you please post a snapshot of your job definition and your background service log.

Stephan

chris
Posts: 20
Joined: Fri Nov 27, 2015 2:19 am

Re: 'Delete after' not applied to snapshots copied to other region

Post by chris » Fri Mar 31, 2017 5:25 am

Thanks for your response Stephan. I emailed the requested files to your support email address with the title of this forum topic in the subject line.

jviola
Posts: 12
Joined: Thu Dec 08, 2016 10:10 pm

Re: 'Delete after' not applied to snapshots copied to other region

Post by jviola » Wed Apr 19, 2017 8:34 pm

Has this been resolved? I too have the same issue.

Thanks.

admin
Site Admin
Posts: 220
Joined: Tue Nov 17, 2015 8:48 pm

Re: 'Delete after' not applied to snapshots copied to other region

Post by admin » Wed Apr 19, 2017 10:58 pm

fixed in 3.3.821. Will be released in the next days.

Stephan

jviola
Posts: 12
Joined: Thu Dec 08, 2016 10:10 pm

Re: 'Delete after' not applied to snapshots copied to other region

Post by jviola » Thu May 11, 2017 3:32 pm

How do I get the latest version?

admin
Site Admin
Posts: 220
Joined: Tue Nov 17, 2015 8:48 pm

Re: 'Delete after' not applied to snapshots copied to other region

Post by admin » Fri May 12, 2017 3:36 pm

Version 3.3.822 is out now. See version history http://www.automaticloud.net/version-history/

Upgrade procedure

Stephan

Post Reply